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Abstract 

CAMS generates files that are imported into Microsoft Dynamics by means of the Integration Manager. The Integration 

Manager sends all contents to the Dynamics Batch where they can be evaluated and then posted directly into the general 

ledger. CAMS keeps an historical record of all postings. See the Billing guide or Online Help for specifics concerning 

posting, TransDoc definition, recreating postings, and accounting reports.  

This document will cover the following topics: 

 Setting up Integration Manager 

 Posting Transactions from CAMS 

 Importing Postings to Integration Manager 
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Disclaimer 

 

Three Rivers Systems, Inc. makes no representation or 
warranties with respect to the contents or use of this guide.  
Further, Three Rivers Systems, Inc. reserves the right to revise 
this guide and make changes to its contents at any time without 
obligation to notify any person or entity of such revisions or 
changes. 

In no event will Three Rivers Systems, Inc. be liable to buyer or 
any other party for any damages, including any lost profits, lost 
savings, or other special incidental or consequential damages 
arising out of the use of or inability to use such product, even if 
Three Rivers Systems, Inc. has been advised of the possibility 
of such damages, or for any claim by any other party. 

© 2014 Three Rivers Systems, Inc. All rights reserved. All 
company and product names included in this site may be 
trademarks or registered trademarks of their respective 
companies. The information contained in these pages is 
subject to change at any time without prior notice. 
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Integration Manager Setup 

Requirements 

The posting workstation must be set up with full read-write access rights to CAMS and 
Dynamics (along with any data paths and network mapping locations). The CAMS export 
file name must be named the same each time it is exported (=WORKCAMS.txt).   

Dynamics Integration Manager should be installed according the instructions that come 
with the software. Once installed, there are a few setup tasks that need to take place. 
These steps will provide the proper links between the data from CAMS and Dynamics. 

 Place Database File 

 Set Database Path 

 Define Source Properties 

 Set Destination Mapping 

Step-by-Step: Placing Database File 

1. Locate the file TRSv7.MDB in <CAMS Enterprise Directory>:\CAMS 
Enterprise\Utils\ on the server where CAMS Enterprise is installed. This file 
stores the integration definitions. 

2. Copy this file to Microsoft Business Solutions\Integration Manager on the 
server where Dynamics is installed.  

Step-by-Step: Set Database Path 

1. Open the Integration Manager.  

2. Follow Tools >Options to the Options window. 

 

Figure 1: Options Window 

3. Click the browser button to locate and select the TRSv7.MDB file from 
<Your Directory>:\Microsoft Business Solutions\Integration Manager. 

4. Click Open. 
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5. Click on OK; the IM will notify you that it must be restarted before the 
directory location can be changed. 

 

Figure 2: Restart Notice 

6. Click OK. 

Setting GL Data Source Properties 

During the integration process, it is necessary to direct Dynamics to the proper 
source files for obtaining relevant data. These sources must be set for both the 
GL posting files as well as the Accounts Payable posting files, which include 
vendor information. 

Step-by-Step: Set GL Source Properties 

1. From the Integration Manager, either click on the Open Integration folder 
or select File >Open Integration.  

 

Figure 3: Integration Manager 

2. Select the eCAMS GL Integration by highlighting this item on the list and 
clicking Open or double-clicking the item. 

 

Figure 4: eCAMS GL Integration window 
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3. Select GL Trx Header. This query uses the output file from CAMS and 
includes sorting options that will allow it to be linked to the GL Header table 
in Dynamics. 

4. Supply the directory path for the GL Posting file. For the GL Trx Header file, 
this location should be <Your CAMS Enterprise Directory>\CAMS 
Enterprise\GL\Workcams.txt.  

 

Figure 5: GL TRX Header Properties 

Note: This is the file created when Post to General Ledger has been executed in CAMS 
Enterprise. Each time this posting from CAMS occurs, the file created is titled 
“Workcams.txt” and resides in the location designated above. This location is the same 
path (GL Output Path) identified in CAMS Billing Configuration in the CAMS Manager 
module. 

5. Click Ok to save your changes. 

6. Repeat the same steps now for GL Trx Line, setting the same file path as 
that for the GL Trx Header. This query defines the detail portion of the GL 
batch entry 
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Setting Properties for Accounts Payable Postings 

The Accounts Payable integration process involves two parts: Accounts Payable 
Vendors and Accounts Payable Items. As you can probably tell by the labels, one 
deals with vendor information while the other deals with transaction details. Both 
processes can be run together or you may choose to run them independently 
(See Running Integration Manager section for specific instructions regarding 
Accounts Payable Integration). Prior to running either of these processes 
however, it is necessary to set the path properties for both AP Vendors and AP 
Items. 

Step-by-Step: Set AP Items Source Properties 

1. From the Integration Manager window, either click on the Open Integration 
folder or select File >Open Integration.  

 

Figure 6: Open Integration window 

2. Select eCAMS AP Item. These are CAMS Enterprise Accounts Payable 
Items. 

 

Figure 7: AP Header 
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3. Double-click APH1 to open the properties detail. 

 

Figure 8: AP Header Properties window 

4. As previously done with the GL Integration, you will set the file path for this 
process. Identify the file used for this query: <Your CAMS Enterprise 
Directory>\CAMSEnterprise\GL\WKCAMSAPH.txt. 

5. Click OK to save changes. 

6. Repeat the same steps now for the CAMS AP Detail Items, but set the file 
path for CAMS AP Detail Items to the following:<Your CAMS Enterprise 
Directory>\CAMSEnterprise\GL\WKCAMSAPD.txt. 
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Step-by-Step: Set AP Vendors Import Source Properties 

1. From the Open Integration window, select eCAMS AP Vendor. This import 
process will import CAMS student information as vendor information. 

 

Figure 9: AP Vendors window 

2. Select eCAMS Vendor. 

 

Figure 10: AP Vendor Properties 

3. Supply the file path for this process: <Your CAMS Enterprise 
Directory>\CAMSEnterprise\GL\VENDOR.txt 

4. Click OK to save changes. 
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Destination Mapping 

After setting the source file paths, it will be necessary to map the data 
destination. 

Step-by-Step: Map Integration Data 

1. Open the Integration Mapping window by clicking Destination Mapping from 
the Open Integration Window, click File > Open Integration > eCAMS GL 
Integration. 

 

Figure 11: Destination Mapping 

2. Click General Journal and set the field sources as displayed below: 

 

Figure 12: General Journal window 

 Batch ID = GL Trx Line.BatchName 

 Transaction Date = GL Trx Line.PostDate 

 Reference = GL Trx Line.Source 

 
 

 



 CAMS Enterprise – GL Posting 

Page 11 of 27 

3. Click the Entries folder. 

 

Figure 13: Integration Mapping 

4. Set the field sources as displayed: 

 Account Number = GL Trx Line.Account 

 Debit Amount = GL Trx Line.Amount 

 Credit Amount = GL Trx Line.Amount 

 Distribution Reference = GL Trx Line.Description 

You are now ready to begin the posting and integration process. 
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Post from CAMS 

The following instructions assume you have selected Dynamics” as the GL 
Output Type in the CAMS Billing configuration screen of CAMS Manager. See 
the Billing chapter for specifics: 

 

Figure 14: Billing Options 

Due to restrictions emanating from the Integration Manager, you must choose 
WORKCAMS.txt as the default output filename for GL posting.  

If multiple users post at your institution, you should be aware that the old 
file will be overwritten with the newest post file. Therefore, it is imperative 
to have a process in place that ensures that the import to Dynamics has 
taken place prior to running a post process. 

AP posts will generate three files: VENDORS.TXT (a vendor information file), 
WKCAMAPH.TXT (a header file) and WKCAMSAPD.TXT (two line items file for 
each transaction).  

Step-by-Step:  Post to General Ledger 

1. From the CAMS Enterprise Home page, click Billing > Billing Accounting 
>Post Options > General Ledger.  The Post to GL screen opens. 

 

Figure 15: Post Options 

2. Select the appropriate term. 

3. Define date range (optional). 

4. Enter the GL Post Date. 

The General Ledger Post Date must correspond to the active ledger year in 
Dynamics or all records will be refused by the Integration Manager. 

5. The Output Path and File Name field is auto populated by the system. CAMS 
will send the export file to this location and the TRS.MDB script will point the 
Integration Manager to the same place. 
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6. Supply Posting Comment, a simple description of the post. 

7. Click Process. A prompt will display confirming that the WORKCAMS.TXT 
file has been created. 

8. Click the Post tab to view the transactions that were exported. 

 

Figure 16: Post to GL Results 

9. The Back button will take you back to the previous screen, and Export will 
allow you to export these transactions to one of the following formats: ASCII, 
Excel, XML or you can produce a Report. 

Step-by-Step: Post Accounts Payable 

1. From the CAMS Enterprise Home page, click Billing >Billing Accounting 
>Post Options >Accounts Payable. The GL Post Accounts Payable 
window opens. 

 

Figure 17: Accounts Payable Posting window 

2. Select the appropriate term. 

3. Define date range (optional). 

4. Enter the GL Post Date. 

Note: The General Ledger post date must correspond to the active ledger year in 
Dynamics or all records will be refused by the Integration Manager. 
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5. Supply Dynamics Options: 

Document Type-These are values used and supplied by Dynamics. 

6. Click “Next Page” to continue entering posting criteria. 

 

Figure 18: AP Posting Detail window 

The Output Path and File Name, <Your Directory>\\CAMSEnterprise\GL, is hard-
coded into the system. 

1. Enter the appropriate filenames for each of the files that will be created 
during the post. 

 Vendor File Name = VENDOR.TXT 

 AP Header File Name = WKCAMSAPH.TXT 

 AP Detail File Name = WKCAMSAPD.TXT 

2. Supply Posting Comment, a simple description of the post. 

3. Select a Report Type. Upon running the post process, CAMS will produce a 
report of the transactions being posted. Options include By Vendor and By 
TransDoc, or you can choose to simply post with No Report. 

4. Click Post Process. You will be prompted to confirm that you wish to continue 
with the post. Once you click Yes, there is no “Undo”. The transactions 
meeting your criteria will be marked as posted and added to the proper .TXT 
files. 

 

Figure 19: AP Posting Results 
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Posting Layouts 

DYN General Ledger Layouts 

 Field 
Number 

Field Name Description 

1 Batch Name System-generated posting batch name 

2 Post Date Post date; read from posting input prompts 

3 Source Transaction Document 

4 Account Account Number 

5 Description Either from 

1) Post in Summary = TransDoc description field, or 

2) Post in Detail = Transaction description field 

Either truncated to 30 characters 

6 Amount Posting Amount 

7 User Posting User 

8 Journal ID Unique Number for each set of transactions, groups a transaction set 
together during journal importation 

DYN AP Vendor Layouts 

Field 
Number 

Field Name Description 

1 VENDORID CAMS StudentUID 

2 VENDORNAME Student name (First Middle Last) 

3 CONTACT Student Preferred Name 

4 ADDRESS1 Billing Address Line 1 

5 ADDRESS2 Billing Address Line 2 

6 CITY Billing City 

7 STATE Billing State 

8 ZIPCODE Billing Zip Code 

9 COUNTRY Billing Country 

10 PHONE Billing Phone Number 

11 ADDRESSCODE Constant “Billing” operates in Dynamics as an address identifier 
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DYN AP Header Layouts 

Field 
Number 

Field Name Description 

1 BATCHNAME CAMS Generated AP Batch Name 

2 DOCNUMBER Transaction Identification Number 

3 DOCTYPE Constant “5” or Credit Memo value in Dynamics 

4 DESCRIPTION CAMS Transaction Description 

5 VENDORID StudentUID 

6 DOCDATE Posting Date from Post/Recreate Options 

7 PURCHASEAMT Absolute Value of Transaction Amount 

8 CHECKAMT Zero 

DYN AP Line Item Layouts 

Field 
Number 

Field Name Description 

1 BATCHNAME CAMS Generated AP Batch Name 

2 DOCNUMBER Transaction Identification Number 

3 DOCTYPE Constant “5” or Credit Memo value in Dynamics 

4 DESCRIPTION CAMS Transaction Description 

5 VENDORID StudentUID 

6 DOCDATE Posting Date from Post/Recreate Options 

7 PURCHASEAMT Absolute Value of Transaction Amount 

8 CHECKAMT Zero 

9 ACCOUNT TransDoc Account Number field (first entry) 

TransDoc Opposing Account Number (second entry) 

10 DISTTYPE Positive values = “2” for Dynamics PAY type, 

Negative values =-“6” for Dynamics PURCH 

11 DEBIT If Positive = Transaction Amount, 

If Negative = Zero 

12 CREDIT If Positive = Zero, 

If Negative = Transaction Amount 
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DYN AX General Ledger Layouts 

Field 
Number 

Field Name Description 

1 Batch Name System-generated posting batch name 

2 Post Date Post date; read from posting input prompts 

3 Source Transaction Document 

4 Account Account Number 

5 Description Either from 

1) Post in Summary = TransDoc description field, or 

2) Post in Detail – Transaction description field 

Either truncated to 30 characters 

6 Amount Posting Amount 

7 User Posting User 

8 Journal ID Unique Number for each set of transaction, groups, a transaction set 
together during journal importation 

9 Original Amount Currency Type Amount 

10 Currency Type Currency Type used for the transaction 

11 Exchange Rate Exchange Rate for the Currency Type at the time of the transaction 

12 Converted 
Amount 

Amount converted per the Exchange Rate 

13 Sort Term Sort Term for the Term set in the transaction 

14 Text Term Text Term set in the transaction 

15 Ref No Transaction Reference Number 

16 OwnerUID StudentUID 
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DYN AX AP Vendor Layouts 

Field 
Number 

Field Name Description 

1 Vendor ID CAMS StudentUID 

2 Vendor Name Student Name (First Middle Last) 

3 Last Name Student Last Name 

4 First Name Student First Name 

5 Middle Name Student Middle Name 

6 Suffix Student Suffix 

7 Address 1 Billing Address Line 1 

8 Address 2 Billing Address Line 2 

9 City Billing City 

10 State Billing State 

11 Zip Code Billing Zip Code 

12 Country Billing Country 

13 Phone Billing Phone Number 

14 Address Code Constant “Billing” operates in Dynamics as an address identifier 

15 System ID StudentUID prefaced with “CE” 
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DYN AX AP Header Layouts 

Field 
Number 

Field Name Description 

1 Batch Name System-generated posting batch name 

2 Doc Number Transaction Identification Number 

3 Doc Type Transaction Document, Used in Dynamics Posting 

4 Description CAMS Transaction Description 

5 Vendor ID StudentUID 

6 Doc Date Posting Date from Post/Recreate Options 

7 Purchase 
Amount 

Absolute Value of Transaction Amount 

8 Check Amt Zero 

9 System ID BillingOwnerUID prefaced with “CE” 

10 Base Currency 
Type 

System Base Currency set in Multi-Currency Configuration 

11 Currency Type Currency Type used for the transaction 

12 Currency Type 
Amount 

Currency Type Amount of the transaction 

13 Exchange Rate Exchange Rate for the Currency Type at the time of the transaction 

14 Base Currency 
Amount 

Base Currency Amount of the transaction calculated at the time of the 
transaction based on the Exchange Rate 

15 Sort Term Sort Term for the Term set in the transaction 

16 Text Term Text Term set in the transaction 

17 Vendor Name Student Name (First Middle Last) 

18 Ref No Transaction Reference Number 
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DYN AX AP Line Item Layouts 

Field 
Number 

Field Name Description 

1 Batch Name System-generated posting batch name 

2 Doc Number Transaction Identification Number 

3 Doc Type Transaction Document, Used in Dynamics Posting 

4 Description CAMS Transaction Description 

5 Vendor ID StudentUID 

6 Doc Date Posting Date from Post/Recreate Options 

7 Purchase 
Amount 

Absolute Value of Transaction Amount 

8 Check Amt Zero 

9 Account Account Number 

10 Dist Type  

11 Debit Debit Amount 

12 Credit Credit Amount 

13 System ID BillingOwnerUID prefaced with “CE” 

14 Base Currency 
Type 

System Base Currency set in Multi-Currency Configuration 

15 Currency Type Currency Type used for the transaction 

16 Currency Type 
Amount 

Currency Type Amount of the transaction 

17 Exchange Rate Exchange Rate for the Currency Type at the time of the transaction 

18 Base Currency 
Amount 

Base Currency Amount of the transaction calculated at the time of the 
transaction based on the Exchange Rate 

19 Sort Term Sort Term for the Term set in the transaction 

20 Text Term Text Term set in the transaction 

21 Vendor Name Student Name (First Middle Last) 

22 Ref No Transaction Reference Number 
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Dynamics NAV GL, AP, and Development GL Layouts 

 Field 
Number 

Field Name Description 

1 Posting Date Post date; read from posting input prompts 

2 Document Date The date of the GL Posting 

3 Document Type Blank by default 

4 Document No. Hard-coded to 1000 

5 External 
Document 
Number 

Blank by default 

6 Dimension 
Combination 

Account Numbers from TransDoc or Development Campaign 
Maintenance 

7 Description TransDoc Description or Development Campaign Maintenance 

8 Amount Total for TransDocs posted in summary or transaction amount 

9 Bal. Account 
Type 

Blank by default 

10 Bal. Account No. Blank by default 

11 Reason Code Blank by default 
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Import Postings into the Integration Manager 

The final process is to import the CAMS file through the Integration Manager into the 
Dynamics batch.  

Step-by-Step: Run Integration Manager 

1. Open the Run Integration window. From the Start menu, Microsoft Business 
Solutions >Integration Manager >Run Integration or from the Integration 
Manager window, Integration >Run. 

 

Figure 20: Run Integration window 

2. The four choices you have are: 

 CAMS PM Group 

 eCAMS Accounts Payable Items 

 eCAMS Accounts Payable Vendors Import 

 eCAMS GL Integration 

The first three are for accounts payable posting. You can either run Vendors 
Import followed by Payable Items, or run CAMS PM Group alone, which batches 
both processes together integrating them in the proper order automatically. 

Here we illustrate the GL process; however Accounts Payable can be run 
similarly by selecting that process. See the field layout descriptions included in 
this section. 

3. Select eCAMS GL Integration. 
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4. Click the Run button; the Integration Manager will open CAMS GL Integration. 
You can see a log of the posting that includes summary and detail screens. 

 

Figure 21: Integration Progress window 

5. Click the View Log button; the Integration Log Viewer screen opens. 

 

Figure 22: Integration Log 
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6. To view specific detail about any message, highlight that item and click the Open 
button; the Integration Log Document Detail screen opens. 

 

Figure 23: Log Detail 

Proofing and Posting the Batch 

Once the Integration Manager has processed this information, the data is viewed in 
Dynamics’ batch and is available for posting to the GL. Here is the process. 

Step-By-Step: Proofing and Posting the Batch 

1. Click Transactions >Financial in the toolbar in order to open the Financial 
menu. 

2. Select Batches from the pull-down menu. 

 

Figure 24: Dynamics Menu 

3. A blank batch entry screen opens. Click the Lookup icon to view a list of all 
current batches, grouped by date.  
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Figure 25: Batch Entry window 

4. Double-click the batch with which you wish to work (or highlight the batch and 
click Select). The Batch ID name will appear in the upper-right hand text field. 
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5. Click the Transactions button at the bottom right of the screen to view detail. 

 

Figure 26: Transaction Entry window 

6. Make any changes as required. 

7. Click Post and follow the prompts to send the information to the general ledger. 

Note: that you can send the posting information to the screen or to the printer first for 
additional review. 
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